Date   
Re: Who has AGC... Fun Facts

Jerry Gaffke
 

You don't have to be a dinosaur.
IF derived is better because it comes on faster, it would take milliseconds to sense low frequency audio,
and in that time the RF/IF stages will go into overload and distort.
So we have audio derived AGC and RF derived AGC (that is where the signal level is detected),
and while most radios then adjust the RF and/or IF gain accordingly, we could also adjust the AF gain.
We might need 3 or 4 different acronyms. ;-)



On Sat, Apr 20, 2019 at 11:06 AM, Scott McDonald wrote:
And because I’m a dinosaur I want to believe a decent IF-derived system is better, though I have to admit the ubitx audio-derived stuff is pretty good. :)
 

Re: More Nextion 3.5" tweaks to do

Joe Puma
 

Thanks Sam, I will give it another look. There is where i was adjusting the lines for vertical positioning I believe,  Its hard to run a test to check if you properly stretched the graph unless you put the code in your Nextion. The simulation mode goes not give you data for the graph. I see Nextion editor has a generator, I was thinking that maybe its signal generator so you can simulate a signal for the graph. 

Joe
KD2NFC

 

On Apr 20, 2019, at 2:52 PM, Sam Tedesco <stedesco619@...> wrote:

On the pspectrum page, tm0 and tmrDisplay populate the empty boxes that show up on full display. If you go thru the nextion code for those two, you'll see a few commands 'fill' and 'xstr' followed by comma delimeted sets of numbers. The main command structure for 'fill' is (x,y,w,h) and the fifth num is a color code. You'll have to run the 2.4" hmi in the editor and figure out the smaller horizontal boxes above and below the graph area. From there, you'll have to calculate your new dimensions based on the 480x320 pixels and subtract out your existing controls to get your new coordinates.

I have to look up the parameters for the 'xstr'...but, probably similar
PITA, but not bad at all. I don't have the i2c setup on my machine so I'm running blind. It's all Nextion code.

Unboxing #ubitx v5 #ubitx

Ron Stauffer
 

I created a short unboxing video of the uBitx v5 and I put it on my maker blog at hamradiomaker.com

Re: Who has AGC... Fun Facts

Adrian Chadd
 

A decent IF system would be great if we did AM/FM, right? :) But it's OK how it is!



-a

Ubitx tx/rx "chatter" (read old thread)

Kelly Mabry
 

Hi all! I have just connected a bc645 4 pin electret mic to my ubitx and am getting a 5 tx/rx "chatter" on transmit on a dummy load, when press ptt. When i release, all is fine, rx is lit and i hear rcv audio.  As a test, i enabled tx stop on the cec software,  and pressed ptt.  The tx indicator lights red for as long as i hold ptt, and then returns green as I unkey. This seems to indicate the ptt works as intended. After unselecting tx stop, the chatter returned. What am I missing? ...continuing to read thread...
73, 

Kelly K5AID 

Re: Ubitx tx/rx "chatter" (read old thread)

Arv Evans
 

Possibly you have connected the audio lead to the PTT circuit and the rig is being keyed by audio.
Possibly you are getting RF into the PTT line (long curly cords are problematic).

_._


On Sat, Apr 20, 2019 at 2:35 PM Kelly Mabry <kmabry2007@...> wrote:
Hi all! I have just connected a bc645 4 pin electret mic to my ubitx and am getting a 5 tx/rx "chatter" on transmit on a dummy load, when press ptt. When i release, all is fine, rx is lit and i hear rcv audio.  As a test, i enabled tx stop on the cec software,  and pressed ptt.  The tx indicator lights red for as long as i hold ptt, and then returns green as I unkey. This seems to indicate the ptt works as intended. After unselecting tx stop, the chatter returned. What am I missing? ...continuing to read thread...
73, 

Kelly K5AID 

Re: More Nextion 3.5" tweaks to do

Ted
 

Sam,

"subtract existing controls".....  Please explain, as I'm willing to dive into it and try.

I've attached my latest tweaks though I'm not at all ready to post it until I check it out in the field and get the graphs right. 



73,

Ted

Audio AVC

Jim Tibbits
 

what with all the fond philosophing and theorizing and debating about avc vs.agc ..behold a REAL circuit ..

found this in an old magazine ...



Modded it to look like this


And included measurements ...something I have not seen on a lot of the others ...

No phase shifters (feedback is DC) so I doubt it will oscillate too much ...works...keeps my ears calm 

AGC/AVC is a complex problem....Simple solutions to complex problems seldom yield positive results

Jim

Re: Remote Head?

Dexter N Muir
 

Great stuff, Ted! VGA cable? hadn't thought of that! :) in true AmateurLogic(.TV) fashion: Cheap-old-man compliant!
73 de ZL2DEX

Re: Audio AVC

Jack Brabham - KZ5A
 

Looks like a simple solution to a complex problem.

73 Jack KZ5A

Re: Remote Head?

Dexter N Muir
 

As an ex-workmate put it (in false Irish brogue): "Good t'inkin', O'Rourke ... yer foired!" :)

73 de ZL2DEX

Re: Ubitx tx/rx "chatter" (read old thread)

Evan Hand
 

That seems to be a common problem depending on antenna and antenna connections.  I had similar issues with an off center fed dipole and RF on the coax braid.  Fixed it with snap on ferrites on the coax, others have used blocking baluns.  Also a .o1 to .1 mf cap on the PTT line to ground has been listed as helping. 

the above are my experiences and thoughts, YMV
73
Evan
AC9TU

Re: Ubitx tx/rx "chatter" (read old thread)

Kelly Mabry
 

Here is what I am using as a wiring guide. Specifically the 4 pin connector is the black as audio, brown as ptt and red as ground. Coming from the front left audio board, J6. (Sunil kit)
Kelly K5AID 

Re: Ubitx tx/rx "chatter" (read old thread)

 

Hi Kelly,

Looks like you should have Pin1 on the new mic going to the red wire connection on the 3-pin board connector.  Also you should have Pin2 on the new mic going to the black wire connection and Pin3 going to the brown wire connection (and no connection to Pin4).  Is this the way you have it?

73,


Mark

Re: Ubitx tx/rx "chatter" (read old thread)

Kelly Mabry
 

Not even close... doh... so embarrassing this is...

Will fix and retry...

Kelly K5AID 

Bitx 40

Earl Warhus
 

I would like to know if the brown wire from Raduino should be
grounded?
Thanks Earl Ve1awc


Re: Ubitx tx/rx "chatter" (read old thread)

Kelly Mabry
 

Update: chatter gone! I wired it as Mark directed, and it doesnt chatter!  

73 & thanks!
Kelly K5AID 

Re: Audio AVC

jim
 

Meets my criteria for a mod

(1) works
(2) minimally invasive
(3) dirt cheap, easily obtainable parts
(4) easy to remove (when it don't work)

Jim

On Saturday, April 20, 2019, 11:43:06 PM UTC, Jack Brabham - KZ5A <kz5a@...> wrote:


Looks like a simple solution to a complex problem.

73 Jack KZ5A

Re: uBitX PTT cycling

MVS Sarma
 

Hi Kelley,
Try to place on 1000pf (1nf) capacitor across the electret mic. Things should improve.
All the best. Regards
Sarma   vu3zmv

On Sun, 21 Apr 2019, 12:27 am Kelly Mabry <kmabry2007@... wrote:
Hi all! I have just connected a bc645 4 pin electret mic to my ubitx and am getting a 5 tx/rx "chatter" on transmit on a dummy load, when press ptt. When i release, all is fine, rx is lit and i hear rcv audio.  As a test, i enabled tx stop on the cec software,  and pressed ptt.  The tx indicator lights red for as long as i hold ptt, and then returns green as I unkey. This seems to indicate the ptt works as intended. After unselecting tx stop, the chatter returned. What am I missing? ...continuing to read thread...
73, 

Kelly K5AID 

Re: uBitX PTT cycling

MVS Sarma
 

Congrats Kelley, you solved it.


On Sun, 21 Apr 2019, 8:39 am MVS Sarma via Groups.Io <mvssarma=gmail.com@groups.io wrote:
Hi Kelley,
Try to place on 1000pf (1nf) capacitor across the electret mic. Things should improve.
All the best. Regards
Sarma   vu3zmv

On Sun, 21 Apr 2019, 12:27 am Kelly Mabry <kmabry2007@... wrote:
Hi all! I have just connected a bc645 4 pin electret mic to my ubitx and am getting a 5 tx/rx "chatter" on transmit on a dummy load, when press ptt. When i release, all is fine, rx is lit and i hear rcv audio.  As a test, i enabled tx stop on the cec software,  and pressed ptt.  The tx indicator lights red for as long as i hold ptt, and then returns green as I unkey. This seems to indicate the ptt works as intended. After unselecting tx stop, the chatter returned. What am I missing? ...continuing to read thread...
73, 

Kelly K5AID