Sensitivity, Spare-Parts and Quality Questions #ubitx #v6.1 #ubitx


DC3AX
 

Hi!

A friend of mine asked me to help her getting the ubitx v6.1 running. It was only giving very low audio, even it seems to receive. I checked all solderings and they looked good. I got some audio but a sensitivity of around -57dBm at 14.200MHz SSB @ 12dB SINAD.

It was suspichious that touching the volume knob makes the speaker "humm"... So I re-soldered some through holes around the audio circuit. I have never had such a bad solder in my life... It doesn't flow good with any of my rework solders or flux pastes. And it hadn't flown correctly when produced originally as many solder points have not soldered through the hole in the PCB. It just looked good, but never connected inside the hole. A combination of flux and lead-free solder was just sucked into the hole at many places.

After that, I got a sensitivity of -95dBm... I still had the issue, that the signal drops in and out if I touch the display or wiggle the Radioino board. So I reflowed that board, the connector on the RF boad and then I found out, that the volume knob has a broken lead. So I unmounted it, set 100R for the volume and a short for the power switch. That brings the unit to -116dBm SSB at 12dB SINAD. That is still not, what I expected to find. 

So my questions are:
Does anyone know a part number for the pot and where to order?
Has anyone measured the sensitivity of his unit and as some values to compare for me?
As this unit was one of the early v6.1 PCBs, does anyone have the same quality issues with this unit?

Thanks for any help!

73 de Ulrich DC3AX / AG1U

Join BITX20@groups.io to automatically receive all group messages.