Re: TX relay problem

Biju Apkrcl
 

It is a common phenomena on ubitx. Some steps to avoid this


1. Replace the mic+ PTT wire with shielded cable. Good quality usb cable can be use.

2. Keep some distance between ubitx and Linier power amplifier.

3. Give earth connection to ubitx case and pa.


This problem will solve with the 1st point itself.




If the ubitx does not come back to receiver mode after transmitting, simply replace the Rx/Tx relay with a good quality relay just like O/E/N make.



 D e VU2TDD
BIJU. A. P.
MARGAO, GOA

On Mon, 13 Apr 2020, 07:58 Dr M T Thomas VU3NWB, <vu3nwb@...> wrote:
Thanks a lot dear Evan. Now it is working.

On Wed, 1 Apr, 2020, 2:40 AM Evan Hand, <elhandjr@...> wrote:
Dr. M T Thomas,

What you describe is a common problem with the uBiTx line of transceivers.  It is most often caused by RF getting into the rig, most likely from either the microphone cord or the coax shield. The best way to verify is to connect to an RF dummy load and see if it happens then.  If it does not stick in transmit mode, then it is RF getting back into the microcontroller.

Two solutions and both can be done.
1 - Put a common mode choke or snap-on ferrite in or on the coax from the antenna.  This is to keep RF out of the radio/shack.
2 - Put a snap-on ferrite on the microphone cord just before the plug and/or add 0.1 uF bypass capacitors on the PTT and microphone input.

Also, be sure that you have good earth ground on the case of the uBiTx.

It always helps to include the version of BiTx when asking for help on this site.  There are multiple models and versions of the BiTx radios, and the best solution can be based on which one you have the issue with.

Hope this helps.
73
Evan
AC9TU

Join BITX20@groups.io to automatically receive all group messages.