Re: The Saga continues.... uBITX v5 Firmware update

N0YWB
 

Windows 7 and Windows 10 will normally automatically install the CH340 driver the first time you connect the Nano or UNO to your PC.
If you have uninstalled driver with the remove files option, You can get the CH340 drivers at
https://cdn.sparkfun.com/assets/learn_tutorials/8/4/4/CH341SER.EXE
Instructions (read past the ads):
https://learn.sparkfun.com/tutorials/how-to-install-ch340-drivers/all

There is no need to uninstall the Arduino IDE to be able to use XLoader or other loaders.
In fact, you can use the AVRdude utility in the Arduino installation to load hex files:
https://forum.arduino.cc/index.php?topic=410618.0

On 2/13/2020 09:38, Daniel Flanagan wrote:
Hello again,

I now have all the tools I need to update my uBITX V5 firmware to
KD8CEC's V1.2 firmware thanks to the help of this group.

My new problem is my computer(s). I am using Windows 7 Professional
service pack 1.

I want to use XLoader to upload hex files to my uBITX V5, however I
can't get the CH340 driver to install properly. No com ports are
recognized after installation (none show up in device manager). When
I install the CH340 driver it tells me that the driver has been
installed in advance, i.e. pre-installed. When I installed the
Arduino IDE it installed a bunch of drivers. I thought that might be
the problem so I removed it (using Revo Pro which removes everything
associated with the program).

I have also tried doing this on my Windows 7 Home premium computer
with the same result. Can anyone tell me what I am missing?

Thanks,
Dan (W3DF)

Join BITX20@groups.io to automatically receive all group messages.