Re: uBITx v5 - with mods

Sandeep Lohia
 


On Mon 10 Jun, 2019, 6:40 PM Ravi Miranda, <ravimiranda@...> wrote:
Hi Sarma, Farhan, Curt,

Thank you all for replying so quickly. I have carried out the following:


a. I have used KD8CEC v1.20 for uBITx V5
b. The #define has been set for V5
c. I have an approx. 100mV signal now (10MHz) and injected that. On
hearing low output at the output, I proceeded to do the math to
calculate the values at each stage.

Here are the equations used. Assuming USB

1. IF_A_FREQ = VFO FREQ - INP_FREQ  [IF_A_FREQ ---- should be a value
of 45MHz so that it can get through the 45 MHz crystal filter
+/-7.5Khz]
2. OP_FREQUENCY = IF_LOCAL_OSC - IF_A_FREQ [OP_FREQUENCY ---- should
be centred on 11.0592 000 (or thereabouts) to get through the Ladder
filter
3. AUDIO_OUT = BFO_FREQUENCY - OP_FREQUENCY [If both match correctly,
we get a ZERO Beat] if the BFO_FREQUENCY > OP_FREQUENCY we get LSB and
the other way we get USB.

Using these calculations, I arrived at a frequency difference of 6660
[strange number if you get the drift :-)  ] No pun intended.

With no calibration, I got nothing, not surprising as the frequency was way off.

Using a frequency meter, I set the calibration of the XTAL from
25.000.000 to 25.003.090 (This value was found using
https://groups.io/g/BITX20/wiki/Si5351-Calibration-Sketch)
The pitch of the tone may have changed, not sure at this stage it was very late.

Using the IF Shift menu option I moved the IFShift  to 6660, and the
tone was clearly there. [LOUD]

Having set this right (so far), I tried the whip antenna in the
balcony (sorry no dipole). There are no signals to be heard at all. So
I have the following questions.
1. Should I change the VFO base frequency to 45.005.000 (given that
the two inductances at both sides are pulling the crystal filter off?
If so what is the best value to set this to, and where in the program
2. Are the equations above correct
3. Instead of the IFShift of 6600 should I be thinking of changing the
#define SECOND_OSC_USB (56054200l)
#define SECOND_OSC_LSB (33940800l)
to better take into account the shift and therefore bring the shift
(as shown in pt.3 above to 0)
4. To improve reception of signals with my antenna, should I add an RF
preamp prior to the antenna input? This could be switched in via a
relay and not kept in the transmit path (not really sure here as I
haven't managed to test transmit section yet.
5. What are the effects of setting lower or higher current values for
SI5351(2,4,6,8)

Is there a worked example that has
a. BASE_VFO_FREQUENCY
b. USB_FREQUENCY
c. LSB_FREQUENCY
d. BFO_FREQUENCY

I can then use the calibration program to generate these three signals
and do measurements?

Many thanks for taking time to help me with this.

Best 73,

Ravi/M0RVI


On Sun, 9 Jun 2019 at 17:31, Curt via Groups.Io
<wb8yyy=yahoo.com@groups.io> wrote:
>
> Ravi
>
> Fantastic on your homebrew scratch build. Based upon all the clues, I wonder if there may be a missing connection at the crystal filter. Either try injecting a signal before and after it. If no signal source, use a wire or antenna to grab some signals and noise at the frequency. Also you might bypass that filter with a wire. If the crystal filter is the issue, then try pressing on each crystal. A smaller chance your BFO is way off, not letting signals through hear that become low enough frequency audio.
>
> Its likely one or two simple things. Yes even touching the input of the audio should cause some buzz.
>
> The ubitx purposely has minimal gain to make an excellent receiver. Audio level to drive a speaker is scarce even when its working well.
>
> Curt
>



--
I'm here to add more value to the world than I'm using up.



Join BITX20@groups.io to automatically receive all group messages.