Re: bad uBitx raduino board

Laurence Oberman
 

What Jerry said but also note if you are using the Arduino IDE, ensure
you set it to the old boot loader when you program it.
Under tools -> processor -> Old Bootloader

On Wed, Apr 3, 2019 at 7:54 PM Jerry Gaffke via Groups.Io
<jgaffke=yahoo.com@groups.io> wrote:

What kind of ideas are you looking for?
One idea might be to use the spare that you have, if the header pins are on the appropriate side of the Nano.
Another idea would be to use one of these:
https://www.amazon.com/Elegoo-Arduino-ATmega328P-without-compatible/dp/B0713XK923

The Nano clones from hfsignals use a CH340 USB interface chip, could be that you need to
download a software driver from the internet for the CH340 to your host computer.
The Elegoo Nano clone referenced above also uses the CH340.
If that's the issue, then your Raduino Nano might be just fine.
When you say "will not allow uploads", exactly how does it go about telling you that?
Could be a clue. ;-)
The original Arduino Nano uses an FTDI USB interface chip.
Other Nano clones may well use completely different USB interface chips.

The FTDI USB interface chip is more expensive than some of the complete Nano clones.

Jerry, KE7ER


On Wed, Apr 3, 2019 at 04:26 PM, ANDREW STEEN wrote:

Hi all.
Finally got around to building my V3 Ubitx. I was having issues with missing menu items, and thought I would upgrade to V4 FW. It appears that the Nano is possibly defective in that it will not allow uploads. I have successfully uploaded the FW on my spare NAno, so I am guessing that the Raduino Nano is bad. Any ideas on a replacement?
Thanks
Andrew
K6STN

Join BITX20@groups.io to automatically receive all group messages.