Re: #ubitx-help Strong Audio Tones in and outside audio receive passband #ubitx-help

Jerry Gaffke
 

I assume you mean changing the Arduino crystal, not cap.

The 16mhz ATMega328P crystal is about 3mm x 1.5mm, goes to  ATMega328p pins 7 and 8.
It is on the top of the Nano, just above the silk for edge pin D5.
Seeing the actual crystal now, and not just looking at datasheets and schematics, I see that it is
extremely small.   I doubt most of those with uBitx in hand will want to mess with it.

I bought some spare Nano clones, I believe they're identical to what's on the Raduino.
Mine have a CH340G chip on the back of the Nano for the USB interface.
This chip has another 3mm x 1.5mm crystal nearby, this one happens to be 12mhz.
    http://www.datasheet5.com/pdf-local-2195953

Quite possibly it is the 12mhz oscillator for the USB interface that is causing the trouble in at least some cases.
Though in post 40432 it was reported that a finger on the Nano's crystal caused the tones to vary,
which suggests that case was due to the 16mhz crystal since the 12mhz crystal is not usually accessible.

None of this was ever a problem on the Bitx40v3, far as I know.
I'd like to think there will be a simple fix, perhaps soldering in a bit of copper tape somewhere for shielding,
or adding a few caps.    Moving the IF would be pretty disruptive.

Jerry



On Fri, Feb 2, 2018 at 11:55 pm, Ashhar Farhan wrote:
changing the arudino cap is going to be a challenge as the arduino is soldered and you need to access it from the underside to desolder it. we had to resort to solder it in as keep it on a socket was leading to bulge and an additional failure point on the board.
 

Join BITX20@groups.io to automatically receive all group messages.