Re: #ubitx-help Strong Audio Tones in and outside audio receive passband #ubitx-help

Ashhar Farhan
 

The best solution is to move the IF to 11 MHz. The caps will remain the same, the crystals will have to change.

-- f

On Sat, Feb 3, 2018 at 1:25 PM, Ashhar Farhan <farhanbox@...> wrote:
changing the arudino cap is going to be a challenge as the arduino is soldered and you need to access it from the underside to desolder it. we had to resort to solder it in as keep it on a socket was leading to bulge and an additional failure point on the board.

- f

On Sat, Feb 3, 2018 at 1:18 PM, Jerry Gaffke via Groups.Io <jgaffke@...> wrote:
Kind of murky, but I think the ATMega328P on the Nano has a max crystal freq of 16mhz.
My datasheet in section 9-3 says 16mhz max when using the "Low Power Crystal Oscillator",
in section 9-4 says 20mhz max when using the "Full Swing Crystal Oscillator".
My guess is that the Arduino set-up routines use the Low Power Crystal Oscillator.
And this document says the Full Swing Crystal Oscillator is going away:
    http://img.digikey.com/Retractions/WC154601%20-%20PCN-12-23-2015.pdf

Significant changes to the crystal frequency will affect timing, things like keyer speed
and delays in closing relays.  Easily fixed, but will require a new sketch.

The 328P on the Nano does operate from a 5v rail. 
(Even when executing Arduino code.)

Adjusting the BFO freq may help the tones, but is not a good solution
because this also affects the range of audio frequencies on receive or transmit
as mentioned in my previous post.
 
Curious that the Bitx40v3 never had this problem, it had the same 16mhz Nano clock and 12mhz BFO
And the BFO was commonly placed both above and below the crystal filter passband.
Perhaps lack of trouble was due to the physical separation the Nano had from the modulator.
On the uBitx, the modulator is right next to the Nano and si5351, which is good because
it ensures clean consistent clocks from the si5351 get to the mixers, but bad if the Nano's 16mhz
throws a monkey wrench into the works.  

If physical separation works on the Bitx40v3, then some simple shielding may work on the uBitx.
Perhaps just a piece of tinfoil or copper sheet taped over the modulator, grounded but otherwise insulated. 

Additional power supply filtering on the Nano may be help, as John suggested.
And caps to ground on the control signals from Nano to uBitx main board.

Would be interesting to move the uBitx BFO to the high side of the crystal filter, closer to 12mhz.
The tones will likely show up on most any uBitx, allowing countermeasures to be tested.

Currently the uBitx BFO is always below the crystal filter to avoid the tones, second LO always at 45-12mhz
Would be nice to  be able to switch sidebands by flipping the BFO to high or low side.
Could then have the second LO at either 45+12 or 45-12mhz, whichever gives fewer birdies
and other such artifacts. 

Jerry



On Fri, Feb 2, 2018 at 07:43 pm, John Backo wrote:
Actually, one could substitute any crystal from 8 MHz
to probably 20 MHz. Theoretically, running the arduino
changes the voltages to about 3.3v, but I and others have
noticed it works fine on 8 MHz and 5v. I would avoid anything
around 12 MHz as that is the USB frequency range and might
interfere. Easily had is a 10 MHz crystal which would probably work
fine. Even a HC49S type would work with just one jumper wire for
one lead (or maybe soldered direct), and the other pin soldered directly.
The old crystal would. of course, need to be removed.

A simple solution is to do what Jerry suggests, and change the BFO
frequency slightly. That may or may not cure the "symptoms"; it certainly
will not cure the problem.

It is likely that uPC crystal radiation is the problem, however. But it may be coming
from inside the radiuno itself. Sometimes (often) this because of Rf leakage back
through the power supply; make sure that is well filtered. Farhan's suggestion
of crystal aging is also very apropos.

Probably the next simplest solution is to replace the nano...



Join BITX20@groups.io to automatically receive all group messages.