Re: #ubitx-help Strong Audio Tones in and outside audio receive passband #ubitx-help

Bill Bates
 

I would be interested in recommended android apps for audio spectrum analysis, there are lots out there but what is a good one (preferably free 😊) God bless, Bill. G6ATO


From: John
Sent: ‎24/‎01/‎2018 08:54
To: BITX20@groups.io
Subject: [BITX20] #ubitx-help Strong Audio Tones in and outside audio receive passband

Hello group,

I need help after spending over a week trying to figure out an issue I have with my uBitx. 

First let me thank Farhan and team for such a great kit. I have built my uBitx around a manpack configuration (External side mounted heatsink, no connection at the back, room for an autotuner).

The issue I have is that I have strong audio tones inside and outside the passband on receive, typically up to 15khz.

I have attached an audio recording and took some audio spectrum snapshots made by placing the phone's microphone near the uBitx speaker. Using this method the dB value of the different FFT frequencies need to be taken with a grain of salt since there are not measured with an oscilloscope. Nevertheless the relative value are of interest here.

As you can see in the spectrums the tones are often near or above the level of the decoded signal which makes them impossible to ignore.

I have observed the following:

1. The tones frequency DO NOT change significantly with tuning up or down, or going through the menu items except when passing over the "CW Speed" option (this can be heard in the recording).

2. Changes in tones frequency DO occur when: 
   2.1 The unit BFO frequency is changed (the most significant variation)
   2.2 When the calibration is changed (this changes the BFO frequency too)
   2.3 When I touch the pins of the SI5351 crystal
   2.4 When I touch the pins of the Arduino's crystal

I have re-done the factory alignment and BFO adjustment several times and always come back to a +16 alignment number and a BFO frequency of 11,996.8Khz.

I have checked or tried the following:

A. Three different power supplies (one Lipo direct, one Lipo through a filtered 12V UBEC, a noise free 13.8V commercial power supply). No change except a small shift in tone frequency).

B. Checked the voltage on the Radiuno: 5.01VDC.

C. Added capacitors from the Radiuno 5V rail to ground (470uF, 0.1uf mica, no change), power supply rail to ground (470uF, no change), 1nF between casing of Arduino crystal to ground (produces a shift in tone, but no reduction in amplitude).

D. I tried a modified software where I would shift the frequencies of both the first and second oscillators by the same amount, thereby leaving the received frequency the same. The result was no change in tones frequency. So only a BFO frequency change produces a shift in tones. 

C. I noticed that when I shift the tones frequency (through BFO adjustment for example), the amplitude of the tones seem to follow the filters passband. This would indicate that they are produced before the sideband filter.

So I have thought of some mixing of the Arduino's crystal frequency with the BFO's one, but this seems to be contradicted by the fact that going over some menu items changes SOME tones.

Needless to say I am out of ideas right now, so your input is welcomed.

Best regards,

John (VK2ETA)


Join BITX20@groups.io to automatically receive all group messages.