Re: W8TEE TFT/ VFO DISPLAY BOARD BOARD

Art Olson
 

Jack

Duh. What's your phrase?  I had a double flat forehead moment. Again thanks for you help and patience 

Art

Sent from my iPhone

On Jul 16, 2017, at 10:14 PM, Jack Purdum via Groups.Io <econjack@...> wrote:

No, that's not what's needed. If you want to read the voltage, you need to pass your supply voltage through a dropping resistor so the voltage doesn't exceed 5V. The end of that resistor is then connected to MYVOLTAGEPIN (A14). The code starting at line 1515 is the block that is responsible for reading that voltage and displaying it on the screen. The Mega should NOT be reading 12V directly on an analog pin. As I said before, this is explain in Rel. 2 of the manual, posted on the group site.

Jack, W8TEE


From: Art Olson <olson339@...>
To: BITX20@groups.io
Sent: Sunday, July 16, 2017 4:50 PM
Subject: Re: [BITX20] W8TEE TFT/ VFO DISPLAY BOARD BOARD

Jack
 
Yes the power pins for the tft/vfo are connected to my supply
 
art
 
From: BITX20@groups.io [mailto:BITX20@groups.io] On Behalf Of Jack Purdum via Groups.Io
Sent: Sunday, July 16, 2017 4:37 PM
To: BITX20@groups.io
Subject: Re: [BITX20] W8TEE TFT/ VFO DISPLAY BOARD BOARD
 
did you connect a line to the voltage pin from your supply?
 
Jack, W8TEE
 

From: Art Olson <olson339@...>
To: BITX20@groups.io
Sent: Sunday, July 16, 2017 4:22 PM
Subject: Re: [BITX20] W8TEE TFT/ VFO DISPLAY BOARD BOARD
 
Jack
 
So after calculating mydividerconstant and recompiling the voltage still floats from 12.2 down to 2.3-2.7. So for now I just commented it out. However it would be great if I can get it to work correctly. Any thoughts
 
Display voltage from my supply (has a digital readout) 12.0v
Voltage at tp3 – 11.6v
 
art
 
 
From: BITX20@groups.io [mailto:BITX20@groups.io] On Behalf Of Jack Purdum via Groups.Io
Sent: Sunday, July 16, 2017 11:06 AM
To: BITX20@groups.io
Subject: Re: [BITX20] W8TEE TFT/ VFO DISPLAY BOARD BOARD
 
Hey, Art...not a problem. The file's only been there a day or two and it will take a while to know it's available. No doubt I'll be posting new versions later on. BTW, my TFT/VFO PCB doesn't have to be used to replace the VFO. It's also a good way to experiment with the Mega 2560 Pro Mini since all of the pins are brought out to header pins, making it easy to attach things for testing. Indeed, you could leave off the support components and use it "stand-alone". I've tried to price it reasonably to encourage you people to experiment with it, to all of our benefit.
 
Jack, W8TEE
 

From: Art Olson <olson339@...>
To: BITX20@groups.io
Sent: Sunday, July 16, 2017 6:56 AM
Subject: Re: [BITX20] W8TEE TFT/ VFO DISPLAY BOARD BOARD
 
Jack
Thanks. Feel a bit foolish for missing the info in the manual
 
Art

Sent from my iPhone

On Jul 15, 2017, at 10:37 PM, Jack Purdum via Groups.Io <econjack@...> wrote:
Art:
 
I'm sure the flicker is because the voltage pin is floating. The code is written so the display updates every 2 seconds, but only if there is a "real" swing in the voltage. You can see the code in loop(), around line 1515. The way to get this to work on the display is explained in the B40 Assembly Manual (Rev. 2) that is in the Files section. Look for "Determining the Displayed Voltage". If you don't want the voltage display activated, just comment out the code block that starts at 1515.
 
Al Peter helped me fix the "encoder noise" is was hearing. Turns out it was a flat forehead mistake on my part. In the process of separating the PA power source from the TFT power source, I managed to introduce a ground loop. Once that was determined it was fairly easy to fix.
 
I'm back onto the other features I want to add.
 
Jack, W8TEE
 

From: Art Olson via Groups.Io <olsonaj6927@...>
To: BITX20@groups.io
Sent: Saturday, July 15, 2017 5:11 PM
Subject: Re: [BITX20] W8TEE TFT/ VFO DISPLAY BOARD BOARD
 
Jack

I must have missed this in the build or setup. The voltage continues to change so it must be floating. I have the tft/vfo connected to the bitx40 power so don't think I have a ground problem. Could you resend the detail about the voltage divider 

"If you connect the display voltage pin to your voltage source, it will flash one or two times at power up, but will only update itself if there is a measurable change in the supply voltage. My guess is that you don't have yours tied to either ground or a voltage divider. As a result, the pin is floating which is read as a new voltage which triggers a screen update.I had mine running several hours last night and it never varied enough to update the field". 

art
 
 
 
Virus-free. www.avast.com
 


Join BITX20@groups.io to automatically receive all group messages.