Topics

DCC 20th Century Limited E7


Mark Fleischhauer
 

I have a question, which may or may not be a DCC question actually.

Last year, I ordered the Kato 20th Century Limited set with DCC pre-installed. The trains finally arrived in December, right before the holidays.

Unfortunately, neither locomotive worked. I sent them back to Kato, and received them back in January. They have the Digitrax DN163K0D decoder.

The information on the packing slip (from the factory) says the following:

"Unit tested function correctly read back o programming rack - no issues found ADDRESS 03"

All my other DCC locomotives work on my T-trak modules with my NCE Powercab system. If I select locomotive 03 and turn up the throttle, nothing happens with either 20th Century Limited locomotive.

I tried resetting them by setting CV8 to 008, and still nothing.

Any thoughts on what might be wrong? I'm very frustrated. I've installed a similar board in my Amtrak P42s, and have the same problem, but I've blamed that on my installation, and that's why I ordered the E7s with DCC factory installed.

Thanks.

Mark