Kenwood D710A running APRSIS32 on Windows 10 tablet with serial to bluetooth adapter

Anthony Mascola

I have been trying to use a US Converters blutronium serial to Bluetooth adapter as I am trying to run a Windows 10 tablet that I can move easily in and out of my Jeep to run APRS to support activities with Search and Rescue, scouting and coordinating while driving off road on overlanding trips.  The vehicle is a daily driver and I need to remove the tablet so the vehicle is not broken into.  I would like to be able to use Bluetooth as the tablet has no serial connector or full size USB port.


So far connecting via Bluetooth has been really challenging.  Things are definitely not stable and are very hit or miss for me and I have been trying various things when I have time over the past year or so.  I was able to run APRSIS32 but sometimes I would not be able to connect to the TNC at all or I would lose my GPS feed (which I am hoping is now fixed with the latest development version) or the program would crash and things are inconsistent.  I was never able to run Winlink Express at all as I can’t open the COM port from the tablet with the same settings that worked intermittently with APRSIS32.  I am wondering if it has something to do with the way I have configured the bluetooth serial port which gets complicated.  


Transceiver: Kenwood D710A

Bluetooth to Serial Port adapter: US Converters Blutronium

                Settings: COM port (selected matching COM port showing in Windows device manager), 9600 baud, 8N1, hardware flow control, DCE selected via DIP switch settings

Tablet: Windows 10 Toshiba Encore WT8-A32, Windows serial port settins: 8N1, 9600 baud, Hardware flow control set

Software: Terminal emulator program Access Port, APRSIS32, Winlink Express, SARTrack with serial port set to matching settings


When I connect to the terminal emulator program Access Port with the following settings (matching COM port, baud rate, 8N1, Flow Control RTS/CTS, CTS output control enabled, DTR control enabled, RTS control handshake, see figures 1 and 2 attached)  and turn on the TNC I can read everything fine that is being sent from the TNC to the terminal emulator but when I try to send any data via the command prompt, I get no response and nothing back.


If I do the same settings with the RT Systems serial to USB cable (with the exception that I don’t have to specify DCE/DTE with the wire cable) I can both send and receive data from the TNC just fine.   There is some setting that is not quite right which prevents my being able to send commands and have the TNC receive and respond to them with the above. 

Has anyone successfully configured a Windows 10 tablet to work with their D710 via bluetooth?  Do you have any idea what I might be doing wrong?  Any suggestions would be greatly appreciated. 







I've been dealing with a somewhat similar problem.  I have a Microsoft Surface Go Windows 10 "tablet" in my new vehicle.  I finally found a way to "install" it so that it's visible for use and connected to my radios, but removable when not in use.  I didn't go the Bluetooth route although I considered it, but I'm not savvy enough to pull that off.  It only has ONE type-C USB port on it.  It also has a charging port for its somewhat proprietary charger configuration.  I wanted to be able to connect my D710A and a separate GPS receiver to the computer (I also have a Yaesu FTM-400XDR that's connected to it also).  I didn't really want to have to come up with a power source to connect to the charging port on the computer.  I discovered that the "new" computers like this can do all sorts of things via that USB port.  In particular, with the right USB hub, I can connect three USB devices AND an external power supply and it will communicate with all those devices and charge the computer's battery (full-blast, not a trickle charge) through that one single USB port ("USB Power Delivery").  Who knew?  I certainly didn't.  I still have to use a serial to USB adapter on the cable from the D710A, but all that extra stuff is hidden under the front seat.

So then the issue became how to get the computer in and out easily without wearing out the USB port.  I found a magnetically-coupled USB-C connector (right angle, no less) that simply uncouples the one and only connection when I want to remove the computer. (

There was one problem I had not counted on.  If I left the computer connected in the vehicle in my garage overnight, the computer's battery would be significantly depleted by the next day.  I discovered that the "turned-off" computer was powering the USB GPS receiver when the external power source was turned off.  Shutting off the computer with its default power settings would not shut off the power to the USB port.  An internet search had me check what the power button does in Windows 10.  It has to really shut it off and not just put it to sleep.  Now it really shuts everything off when I turn it off.

I know this doesn't directly address your problem, but I thought it might give you some alternative ideas...


Anthony Mascola

Hi Gil,
Thanks for sharing your setup.  I really like it.  I purchased a used Toshiba Encore WT8-A32 on eBay as it was the only Windows 10 tablet that I could find that had a built in GPS receiver.  It turns out however that getting the GPS feed from the tablet and Windows is quite challenging and it has not been very useful and I wouldn't recommend this idea to others at least from my limited experience.  I had hoped to minimize wires and klunkiness and have as clean a setup as possible so that I might be able to remove the tablet from the vehicle and still use it with various mapping software but it has been an elusive goal.  I can only use the internal GPS receiver with the Windows Maps app but other software such as Terrain Navigator Pro can't find the GPS feed even with creating a virtual serial port to output this data. I have to use the K6VHF GPS unit attached to the D710 with APRSIS32.  Unfortunately SARTrack can't even utilize the K6VHF GPS feed and requires a separate external serial GPS unit which I am still in need of acquiring and klunkiness and wires and time and expense galore have been the bane of my efforts to date.

The tablet was inexpensive and appeared promising initially but the above limitations I ran into with Windows 10 and the internal GPS data not being easily acceptable for other software plus the limitations of the single USB micro-B connector for charging and data communications has proven challenging.  It is a little tricky I have found to use the tablet as it requires a special custom Y cable to trick the computer into allowing data exchange and power at the same time.  The USB-C connector seems to have a lot of advantages over the micro USB port in this regard.  I had a problem where I wore out the first micro USB port from removing and inserting the cable repeatedly and tried to repair it and ended up having to replace the entire tablet with another one on eBay as I was unable to repair it and also incurred damage due to non sine wave AC power from the power supply plugged into the inverter described below.  Your setup with the magnetic connector is very good.  

Getting the US Converters Blutronium configured properly is also still elusive and has consumed dozens of hours of time and despite numerous exchanges with the manufacturer, I have yet to get it running consistently with Winlink Express.  I can get it running intermittently with APRSIS32 but I can't count on it.  I have given up on this for the time being as I just don't have time to keep trying and have been using the RT systems serial to USB connector.  The USB to serial cable introduces a challenge with the tablet above as the connector itself requires power to enable it to function and the special Y cable to connect it all which is also somewhat finicky.  The power required to charge the tablet is greater than the 0.5A that is typical for a USB port and requires a more significant power supply.  If I plug the tablet into the inverter built into the Jeep with a AC to DC wall wart type of power supply I have encountered damage to the motherboard possibly because the inverter is not a pure sine wave output.  This was another factor leading to my needing to replace the first tablet and I have run it off of a power bank since that time.

I post this to assist others in being aware that though this would appear to be a straightforward project, but at least for me it has been quite challenging and at times very frustrating.  I think the Microsoft Surface or other tablet with a USB C connector and hub and USB to serial cables would be the way to go.  If anyone out there has ever been successful in getting a Windows tablet and bluetooth to serial connector running with APRSIS32 and other software such as SARTrack or Winlink Express I would love to know how you configured this with the Kenwood D710. 

t would be nice to see how other persons are running a Windows tablet in their vehicles.  Despite the klunkiness and time and frustration above, I love being able to send Winlink packet and email and use APRS on the beautiful color screen of the tablet and also to have the tablet to program the transceiver and use the internet for general computing use when in cell range.   it would be nice to share ideas on how to streamline this process for others.  So far I like your setup the best Gil of all that I have heard about. 


It does sound as if you've had your challenges.  My setup is not uncomplicated but I've made it as tidy and neat as I can without going totally "wireless".  I do have the ability to use my D710A for Winlink.  There's a setup predetermined for that radio in Winlink and I just used that, dialed up the nearest gateway station and it worked.  Obviously it's not doing APRS at the same time - but my FTM-400 can run in APRS mode at the same time if necessary.

Here are a few more of the components I used for my arrangement:

This is the hub I got that also allows power to be fed to the Surface Go:

I use one USB port for the connection to the D710A Control head with the PG-5 (?) cable and a serial to USB adapter.  Another USB port is used for the USB powered GPS receiver I use for the Surface Go.  The last port is used for the FTM-400XDR connection to the Surface Go for when I use that at the APRS radio with APRSIS32.  I got another el cheapo "regular" hub I can piggyback onto one of those ports to get a few more ports if necessary.

This is the mobile power supply I got to feed power to that hub:

I was tempted to cut off the cigarette lighter plug and use Anderson Power Pole connectors but I didn't want to circumvent the fuse in the plug so I had to use an inline cigarette lighter socket with a Power Pole cord to feed that power supply.  I guess I could have put a Power Pole inline fuse into its power feed, but I already had the other parts.  I try to keep everything set up with Power Pole connectors.

I used two of these as the "disconnects" for the wiring to the vehicle battery (which is additionally fused at the battery) and for the wiring to the "radio" battery (which is also fused at the battery terminals - it's a big deep-discharge marine battery) that is hooked to a West Mountain Radio ISOPower+ isolation device.  That cut down on some control wiring.

The "radio" battery is in the back.  I was never quite sure how well the isolator gadget was working regarding charging that battery so I found one of these to keep an eye on it with my phone.  I would have preferred a Windows application, but I have to settle for my phone.:

I keep an eye on the engine electrical system voltage with one of these:

Yes, this all added up to a tidy sum, but I wanted to try to do this installation as well as I could.  It will serve me for many years.  I still have my other 15-year old vehicle from which I learned a lot about installing radios.  I plan to keep this one as long as possible too, so the cost will be spread out over many years.  I only get to do this infrequently...