https maps (Dev: 2020/05/14 23:14)


Lynn Deffenbaugh
 

The plan is that the "Migrate" button will scan through the legacy directory-based tiles and load them into an associated MBTiles file.  If the tile is already in the database, it will only be loaded if the file's revision date is later than the load date in the database.  At the end of the migration, I plan to ask if you want to keep the files or have them deleted for you.

Sound like a good plan?  Now I just have to implement it!

Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

On 5/15/2020 10:24 AM, Fred Hillhouse wrote:
Added teaser "Migrate" button to non-MBTiles-backed tile sets.

This mean I can retain the old file structure for the tiles? Or migrate old into new?

Fred N7FMH



--
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus



Fred Hillhouse
 

Added teaser "Migrate" button to non-MBTiles-backed tile sets.

This mean I can retain the old file structure for the tiles? Or migrate old into new?

Fred N7FMH



--
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus


Lynn Deffenbaugh
 

Support a new check-box "https://" in the upper right corner of the Tile Set configuration dialog.  Yes, it works for non-MBTiles tile sets now!

Added teaser "Migrate" button to non-MBTiles-backed tile sets.

Added a new dialog for showing configuration of MBTiles-sourced (has a URLFormat metadata) Tile Sets.

Revamped some internal data structures around MBTiles to make them more dynamic and avoid opening multiple paths to a single MBTiles database.

Better handle server ports for http (80) and https (443).  There was an issue where a tile set would default to 80 but attempt to use the https protocol which continually failed.  A Port of zero (0) will select the proper default for the URL's protocol.

Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

PS.  If you use the new https:// checkbox, you need to make sure you either specify a port of 0 or 443, not 80!