Topics

APRSIS Internet to RF | I-Gate | Software to Kenwood TM-D710A

vu2yep
 

Hi All

Seasons Greetings!!

I am an active users of APRS32 Windows App with Kenwood TM-D710A. I have Yaesu FT-2D from New Delhi, INDIA.

I am currently getting APRS Packets Transmitted from Computer APRS32 software to Radio and then received on my FT-2D. Main SSID, Objects created by me and TM-D710A SSID is getting transmitted at regular intervals. 

However, I also want that all VU prefix station beaconing via Internet and showing up on my computer screen or specific prefix to get through from the Internet on to RF via Kenwood TM-D710A then get displayed onto our APRS enabled radios like Yaesu FTM-400 or FT-2D or Kenwood TH-D74 etc;  so that I and other users on the APRS freq. can get APRS data from other VU stations and WX stations of INDIA as well as other my usual SSIDs. 

Would appreciate where and what specific changes to be made? 

Happy Holidays!!


Thanks & Regards 73 Karan, VU2YEP

Fred Hillhouse
 

Typically you don’t want to push data from the APRS internet servers over RF. It has the potential to overload the APRS frequency and then no one can use it. Rather than push all “VU*”, it would be best to pick out the important stations and only push those.

 

From previous postings:

 

Follow the instructions on the Wiki below to upgrade to the latest Development version.

http://aprsisce.wikidot.com/doc:development-version

 

APRSISCE/32, in the Development version only, supports gating packets

from the APRS-IS to local RF based on a filter setting. This is

experimental at this point, and is not persistent, so you need to re-do

the sequence after any IGate restart.  To set up this -IS to RF gating,

follow this procedure.

 

1) Hit Control-G with the main window focused.  This will bring up a

"Test Filter" window where you enter your desired filter.  In your case,

the filter would be b/VE2SE-2.

 

2) Once the filter is entered, a new FilterTest trace window will come

up.  I encourage you to monitor this window for some period of time

(hours or days) to ensure that ONLY your desired packets are being

selected by the filter.  Otherwise, go back to the Control-G window and

tweak the filter.

 

3) Once you are satisfied with the filter setting, you can promote the

filter to an IGate filter by typing Contol-I (eye) with the main window

focused.  You will be asked to confirm your intent to set the IGate

filter.  After clicking Yes, all filter-selected packets should be

transmitted to RF as 3rd party packets.

 

4) Once you have confirmed your gating intent, a new IGate(Filter) trace

log will open that will show all packets transmitted due to this setup.

 

 

 

Best regards,

Fred N7FMH

 

From: aprsisce@... [mailto:aprsisce@...]

Sent: Wednesday, December 26, 2018 9:34 AM

To: aprsisce@...

Cc: Karan Bakshi

Subject: [aprsisce] APRSIS Internet to RF | I-Gate | Software to Kenwood TM-D710A

 

 

Hi All

 

Seasons Greetings!!

 

I am an active users of APRS32 Windows App with Kenwood TM-D710A. I have Yaesu FT-2D from New Delhi, INDIA.

 

I am currently getting APRS Packets Transmitted from Computer APRS32 software to Radio and then received on my FT-2D. Main SSID, Objects created by me and TM-D710A SSID is getting transmitted at regular intervals. 

 

However, I also want that all VU prefix station beaconing via Internet and showing up on my computer screen or specific prefix to get through from the Internet on to RF via Kenwood TM-D710A then get displayed onto our APRS enabled radios like Yaesu FTM-400 or FT-2D or Kenwood TH-D74 etc;  so that I and other users on the APRS freq. can get APRS data from other VU stations and WX stations of INDIA as well as other my usual SSIDs. 

 

Would appreciate where and what specific changes to be made? 

 

Happy Holidays!!

 

 

Thanks & Regards 73 Karan, VU2YEP


Virus-free. www.avast.com

vu2yep
 

Hi Fred N7FMH

Thank you for your valuable inputs.

I am using the software in Windows 7 computer. I am able to do the test using CTRL-G  as suggested given filter example - b\VU2RCY-13 (weather station) and some more Calls,  but I do not get to see anything on CTRL+I.

Plus, I am yet to make changes to the software. the Dev version. 

Do I need to place the filter under Configure > General > And its a filed called Filter? what all filters should I use so that only VU Call Signs be it station or weather station from INDIA they get Igated IS-RF when they show up on the software as beacon?

We can connect directly as well, if need be.

Appreciate your time and support.

73
Karan, VU2YEP


Fred Hillhouse
 

Greetings Karan,

 

APRSIS32 needs to be running development mode. These two links are important.

http://aprsisce.wikidot.com/doc:editing-xml-configuration

http://aprsisce.wikidot.com/doc:development-version

 

As for performing IS to RF gating, I haven’t tried it. Others will need to chime in. There has also been discussion in the past so the archives might give some clues.

 

Best regards,

Fred N7FMH

 

From: aprsisce@... [mailto:aprsisce@...]
Sent: Thursday, December 27, 2018 6:11 AM
To: aprsisce@...
Subject: [aprsisce] Re: APRSIS Internet to RF | I-Gate | Software to Kenwood TM-D710A

 

 

Hi Fred N7FMH

 

Thank you for your valuable inputs.

 

I am using the software in Windows 7 computer. I am able to do the test using CTRL-G  as suggested given filter example - b\VU2RCY-13 (weather station) and some more Calls,  but I do not get to see anything on CTRL+I.

 

Plus, I am yet to make changes to the software. the Dev version. 

 

Do I need to place the filter under Configure > General > And its a filed called Filter? what all filters should I use so that only VU Call Signs be it station or weather station from INDIA they get Igated IS-RF when they show up on the software as beacon?

 

We can connect directly as well, if need be.

 

Appreciate your time and support.

 

73

Karan, VU2YEP

 

 


Virus-free. www.avast.com

vu2yep
 

Hi Fred N7FMH

Hope you are doing well.

Sure, During weekend I will check on these links and try to follow it. Also, if another station has made it possible please share your experience. IS to RF using Windows computer and Kenwood TM-D710.

Happy weekend. In case we don't chat between now New Year... I wish and every one Happy n' Prosperous New Year 2019.

Lots and loads of APRS activity all.

Regards
Karan, VU2YEP

Chris Morrison
 

I just tried to iGate from IS to RF but I couldn't getting it working like I used. I see from Karan post from Dec 18 he had a similar problem with no answer posted to the forum. 

Many years ago I used to iGate IS only stations within a 5km radus of my home station. I would do this by using the development version, setting the IS filter test to "m/5" by pressing Ctrl+G then setting the igate to enable by pressing Ctrl-i. But now when i try it Ctrl-i doesn't do anything. 

I am running APRSIS32 build on 2019/01/23. Has the steps to enable IS to RF igating changed or am I missing something?

Chris
MM1PTT / MB7UCM 

Lynn Deffenbaugh
 

You have to set up your test filter first with Control-T and then watch the FilterTest trace log for a while to make sure you're seeing the packets you expected.  Then you have to have focus on the main window when you enter the Control-I (eye) to get the confirmation prompt about using the current filter for -IS to RF gating.

Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

On 5/20/2019 12:19 PM, chris.mm1ptt@... [aprsisce] wrote:
I just tried to iGate from IS to RF but I couldn't getting it working like I used. I see from Karan post from Dec 18 he had a similar problem with no answer posted to the forum. 

Many years ago I used to iGate IS only stations within a 5km radus of my home station. I would do this by using the development version, setting the IS filter test to "m/5" by pressing Ctrl+G then setting the igate to enable by pressing Ctrl-i. But now when i try it Ctrl-i doesn't do anything. 

I am running APRSIS32 build on 2019/01/23. Has the steps to enable IS to RF igating changed or am I missing something?

Chris
MM1PTT / MB7UCM 

patrick lambert
 

Can you send me the link to download a newer version. The version have got is in 2012 I think.

Télécharger Outlook pour Android


From: aprsisce@... on behalf of chris.mm1ptt@... [aprsisce]
Sent: Monday, May 20, 2019 12:19:29 PM
To: aprsisce@...
Subject: RE: [aprsisce] Re: APRSIS Internet to RF | I-Gate | Software to Kenwood TM-D710A
 
 

I just tried to iGate from IS to RF but I couldn't getting it working like I used. I see from Karan post from Dec 18 he had a similar problem with no answer posted to the forum. 


Many years ago I used to iGate IS only stations within a 5km radus of my home station. I would do this by using the development version, setting the IS filter test to "m/5" by pressing Ctrl+G then setting the igate to enable by pressing Ctrl-i. But now when i try it Ctrl-i doesn't do anything. 

I am running APRSIS32 build on 2019/01/23. Has the steps to enable IS to RF igating changed or am I missing something?

Chris
MM1PTT / MB7UCM 

Lynn Deffenbaugh
 

Please follow the instructions at:

http://aprsisce.wikidot.com/doc:development-version


Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

On 5/20/2019 1:20 PM, patrick lambert lambertinos@... [aprsisce] wrote:
Can you send me the link to download a newer version. The version have got is in 2012 I think.


From: aprsisce@... on behalf of chris.mm1ptt@... [aprsisce]
Sent: Monday, May 20, 2019 12:19:29 PM
To: aprsisce@...
Subject: RE: [aprsisce] Re: APRSIS Internet to RF | I-Gate | Software to Kenwood TM-D710A

I just tried to iGate from IS to RF but I couldn't getting it working like I used. I see from Karan post from Dec 18 he had a similar problem with no answer posted to the forum.


Many years ago I used to iGate IS only stations within a 5km radus of my home station. I would do this by using the development version, setting the IS filter test to "m/5" by pressing Ctrl+G then setting the igate to enable by pressing Ctrl-i. But now when i try it Ctrl-i doesn't do anything.

I am running APRSIS32 build on 2019/01/23. Has the steps to enable IS to RF igating changed or am I missing something?

Chris
MM1PTT / MB7UCM

Greg Depew
 

Control-T?? I have the 2019/01/21 version and   Control-G still brings up the test filter. Control-T just forces a transmit. 



Greg KB3KBR Sent from my Verizon, Samsung Galaxy smartphone


-------- Original message --------
From: "'Lynn W Deffenbaugh (Mr)' kj4erj@... [aprsisce]"
Date: 5/20/19 13:44 (GMT-05:00)
To: aprsisce@...
Subject: Re: [aprsisce] Re: APRSIS Internet to RF | I-Gate | Software to Kenwood TM-D710A

 

Please follow the instructions at:

http://aprsisce.wikidot.com/doc:development-version


Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

On 5/20/2019 1:20 PM, patrick lambert lambertinos@... [aprsisce] wrote:
Can you send me the link to download a newer version. The version have got is in 2012 I think.

Télécharger Outlook pour Android


From: aprsisce@... on behalf of chris.mm1ptt@... [aprsisce]
Sent: Monday, May 20, 2019 12:19:29 PM
To: aprsisce@...
Subject: RE: [aprsisce] Re: APRSIS Internet to RF | I-Gate | Software to Kenwood TM-D710A
 
 

I just tried to iGate from IS to RF but I couldn't getting it working like I used. I see from Karan post from Dec 18 he had a similar problem with no answer posted to the forum. 


Many years ago I used to iGate IS only stations within a 5km radus of my home station. I would do this by using the development version, setting the IS filter test to "m/5" by pressing Ctrl+G then setting the igate to enable by pressing Ctrl-i. But now when i try it Ctrl-i doesn't do anything. 

I am running APRSIS32 build on 2019/01/23. Has the steps to enable IS to RF igating changed or am I missing something?

Chris
MM1PTT / MB7UCM 

Lynn Deffenbaugh
 

Greg is correct. I'm being stupid on vacation. Control-G is indeed the test filter trigger. Gotta do better proof-reading and test what I write before sending it!

Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

On 5/20/2019 1:52 PM, Greg Depew goatherder_4891@... [aprsisce] wrote:
Control-T?? I have the 2019/01/21 version and Control-G still brings up the test filter. Control-T just forces a transmit.



Greg KB3KBR Sent from my Verizon, Samsung Galaxy smartphone


-------- Original message --------
From: "'Lynn W Deffenbaugh (Mr)' kj4erj@... [aprsisce]"
Date: 5/20/19 13:44 (GMT-05:00)
Subject: Re: [aprsisce] Re: APRSIS Internet to RF | I-Gate | Software to Kenwood TM-D710A

Please follow the instructions at:

http://aprsisce.wikidot.com/doc:development-version


Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

On 5/20/2019 1:20 PM, patrick lambert lambertinos@... [aprsisce] wrote:
Can you send me the link to download a newer version. The version have got is in 2012 I think.


From: aprsisce@... on behalf of chris.mm1ptt@... [aprsisce]
Sent: Monday, May 20, 2019 12:19:29 PM
To: aprsisce@...
Subject: RE: [aprsisce] Re: APRSIS Internet to RF | I-Gate | Software to Kenwood TM-D710A

I just tried to iGate from IS to RF but I couldn't getting it working like I used. I see from Karan post from Dec 18 he had a similar problem with no answer posted to the forum.


Many years ago I used to iGate IS only stations within a 5km radus of my home station. I would do this by using the development version, setting the IS filter test to "m/5" by pressing Ctrl+G then setting the igate to enable by pressing Ctrl-i. But now when i try it Ctrl-i doesn't do anything.

I am running APRSIS32 build on 2019/01/23. Has the steps to enable IS to RF igating changed or am I missing something?

Chris
MM1PTT / MB7UCM

Chris Morrison
 

Control-G brings up the Trace(Filtertest) log, I can see the hits from the APRS-IS, my RF radio port and internal.  But nothing happens when i press Control-I (eye) with the main window in focus or the with the Filtertest in focus. I also tried its with filtertest minimised and closed with difference.

I did have it working a long time ago, so thought there might be something in my configure file stopping me. I tired using another instance, same APRSIS32 version but different conf file. Control-I isn't didn't appear to do anything with that instance either. 

Chris
MM1PTT / MB7UCM

Lynn Deffenbaugh
 

Check About and see what version you are running.  The 2012 version doesn't do it, but all recent development versions should support it.  Here are the conditions of Control-I:

if (ActiveConfig.Update.Development && ActiveConfig.APRSIS.IStoRFEnabled && IGateEnabled && !IGateReceiveOnly && TestFilter.FilterText && *TestFilter.FilterText && !TestFilter.HasErrors && IsTraceLogEnabled("FilterTest"))
1) It has to be a development version
2) Your APRS-IS port must be IS to RF enabled
3) Your Igate must be enabled (see below)
4) Your IGate cannot be ReceiveOnly
5-6) You must have a non-blank test filter
7) Your test filter must be error-free
8) Your FilterTest trace log must be enabled

IGate enabled means:
1) RF Ports are enabled
2) Internet access is enabled
3) APRS-IS port is enabled
4) APRS-IS port is IS to RF enabled OR RF to IS enabled
5) At least one port is RF and also IS to RF or RF to IS enabled

So there's lots of menu checkboxes to verify AND checks on both your APRS-IS port configuration and your RF port configuration.  Once you have everything enabled (and assuming you're on a development version), Control-I should bring up the confirmation prompt.

What is the callsign-SSID of the IGate instance in question?  I can answer some of these questions with remote APRS message queries.

Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

On 5/21/2019 8:49 AM, chris.mm1ptt@... [aprsisce] wrote:
Control-G brings up the Trace(Filtertest) log, I can see the hits from the APRS-IS, my RF radio port and internal.  But nothing happens when i press Control-I (eye) with the main window in focus or the with the Filtertest in focus. I also tried its with filtertest minimised and closed with difference.

I did have it working a long time ago, so thought there might be something in my configure file stopping me. I tired using another instance, same APRSIS32 version but different conf file. Control-I isn't didn't appear to do anything with that instance either. 

Chris
MM1PTT / MB7UCM

Chris Morrison
 

Problem solved. The issue was the APRS-IS port didn't have the IS to RF port checked. The RF port did have it checked and packets were hitting the tracefilter from the APRS-IS so I didn't think there was an issue from the APRS-IS side. 

My other instance didn't work but for that one it was easier to delete the conf file and start again from fresh rather than troubleshoot. 

Your previous message is very useful and I've archived in my email inbox for future reference. I would be useful to have that iGate troubleshooting list on the wiki. 

Many thanks,
Chris
MB7UCM / MM1PTT