Re: How to make a new PORT that listens to a soundcard?

Rob Giuliano
 

One option, which might not do everything you want, but will split the decodes into ports is to use AGWmonitor.  This is a kind of TCP sniffer for AGW information.
It will have a tab for each AGWpe port in use, and a tab of combined ports.

By jumping between the tabs for each device, you can see which has more decoded messages.  It also keeps an mheard list and see which has more data.

You MUST keep the port numbers on the far right unique for each port.  AGW tends to asume a dual port TNC and starts with KISS ports IDs of 0 (zero) and 16.  When you create the second port, you must change the ports.

Port1 and Port 2 would be on the first "Dual Port" AGW soundcard and use 0 and 16.
  If onlu a single port is designated, then use KISS port ID 0
Port3 and Port 4 would be on the second "Dual Port" AGW soundcard and use 8 and 9 (or something).
  If onlu a single port is designated, then use KISS port ID 8.

Otherwise you have 2 different TNCs reporting on the same KISS ID (0) on the same TCPIP port (8000).  Not sure of the impact, but I do know the software won't be able to tell which is which - if it even works properly. 

Of course, as discussed, a second instance on a different TCPIP port will also solve this issue.




Robert Giuliano
KB8RCO



On Tuesday, December 24, 2019, 9:03:35 AM EST, Lynn Deffenbaugh <kj4erj@...> wrote:


AGWpe supports multiple ports.  They all come over the single TCP/IP
port connection to APRSISCE/32.  APRSISCE/32 will receive from all
channels and display the receptions, but it can only transmit on the
"first" (0) port configured in AGWpe.

So, if you ahve a single instance of AGWpe reading both your D710's
audio direct as well as the SDR, you're already receiving packets
decoded from both channels.

The "problem" is that, IIRC, you're trying to compare antenna
performance.  APRSISCE/32 isn't doing to differentiate visibly which
packet was received from which AGW-internal port, so you won't be able
to tell which antenna/radio solution is working better.

When I run trials to compare TNCs and decoding abilities, I usually fire
up a second copy of APRSIS32 and configure a dedicated port into that
instance.  Then I can put the two windows side-by-side, configure the
scroller to show RF-only, and just watch the packets come in as well as
what accumulates on the map (View / RF / All).

To run a second copy of APRSIS32, simply copy the .EXE into a new
directory and double-click it there.  You'll need to use a unique -SSID
on this second instance and configure your new port from there.

I can't help you with getting 2 instances of AGWpe running though, but
you'll want that as opposed to DireWolf to compare your antenna.  It is
important to have as much the same as you can and that definitely
applies to the actual audio decoder.

Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

On 12/24/2019 8:49 AM, KD7YZ Bob wrote:
> Season's greetings Lynn, Rob, Jack:
>
> I am using AGWPE (Paid), called "Packet Engine Pro".
> In AGWPE (PEP) I set up a single TNC from "SoundCard".
> This Device is the Data-Port-Cable going from the D710 Data-port to the SignaLink soundcard device.
> I find that the data Port, "however" I have the D710 configured, is actually reading Ch-B ...
> I have a screenshot showing the Sound-Control-Panel and this device ...many green bars when I open the Squelch knob on the right-hand channel.
>
> However, I see no way on this web interface to add a jpeg. And I think I already said I stopped email delivery due to many many missing posts after I ask a "Q" on this board via email. Now just the Web Interface.
>
> So, AGWPE also is read by UISS. I wsee the Sat Traffic from the Ch-B side.
>
> In APRSIS32, I setup an AGW Port to see TelNet --- localhost Port 8000" from AGWPE .... which I assume is exporting the Data-Cable (D710) data, which I know to be Ch-B st at 145.825.
>
> Now to th heart of my question:
>
> I use SDR-Console Version-3. Feeding in to that is one of my RTL's.
> Output of that SDR-Console "Radio" is to Virtual-Audio-Cable Line-1 .... which is also listed in the Soundcard-App from Dev-Man.
>
> But how would that AGWPE Port-2 get to APRSIS32?
>
> "localhost" is already in use. It "IS" logical that AGWPE could Rx on Port One from Data-Port of D710 Ch-B on 145.825 and "whatever I set SDR-Console to would also at this time be 145.825 on a SPID rotator, would also be sending data through AGWPE TelNet on port 8000 ...
>
>
> And ?
>
> Since there is only ONE setting in AGWPE (PEP) where  I can set a port (8000 in the default case, how do I pipe output from a second AGWPE port to APRSIS32?
>
> Maybe run a UZ7HO standalone soundmodem into localhost port 7999 or 8001, or ?
>
> would liked to have added some "settings" specific screenshots to this. However I am still an uneducated newbie and can't figure how to do it.
>
>
>
>
>
>
>
>



Join APRSISCE@groups.io to automatically receive all group messages.