Re: D74 with APRSIS32 won't transmit


Greg D
 

Thanks, Rob. 

Not sure what it was, but it's working now.  I was already in Dialout, but added Modem and UUCP to the groups.  Logged out and back in and it's working.  What's odd is that I could write to the serial device just fine from putty (sending the ID command to the D74), and receive just fine with APRSIS32, but not send.  {Shrug}

So, for field day I don't have to switch between Linux and Windows to run the various apps that I need.  I only wish I could get the D74's Bluetooth connection to link up with Linux.  Works fine in Windows with APRSIS32, but then I'm, blocked when I try to run gpredict.  The Doppler tracking isn't working under Windows, and I'm really hoping to snag 100 pts with AO-92 mode L/v.  Perfect pass at 11:09 am local on Saturday.

Greg  KO6TH


Rob Giuliano kb8rco@... [aprsisce] wrote:

 
Although I am not a D74 user, I have worked with various serial interfaces on Windows, Linux, and other operating systems.

A couple additional things to consider:
* Could be that the radio is expecting hardware flow control (common with KISS mode TNCs to ensure buffers don't fill)
   This should be a setting in the radio and the Linux system.  Linux uses stty to control the port settings. 
* If the D74 is using Hayes AT commands, you typically go between "command mode" and "use mode" with by sending +++
  I'd be surprised if Kenwood is using the Hayes command set though.
 
Robert Giuliano
KB8RCO



First thing to check is whether you have write permission for /dev/ttyACMo.
Most serial devices belong to the "dialout" group (/etc/groups).  Have you added your username to that group?

If that isn't it, answer these questions:
   What does the "port log" in APRSIS32 say when you transmit?

   What happens if you leave PuTTY (under WINE or compiled fro Linux) connected for awhile?
      Does it show KISS packets or clear text?
 
The ACM# means that Linux thinks it is a modem (rather than a RAW serial device).  This typically isn't a problem, but can be if the modem state is "awaiting AT commands".  You can lookup an AT command to put in the OpenCmd are to ensure it isn't in a "command mode" (could explain the response to "id" as opposed to sending "id" out the TNC portion).

Robert Giuliano
KB8RCO



From: "Greg D ko6th.greg@... [aprsisce]"
To: aprsisce@...
Sent: Thursday, June 21, 2018 2:55 PM
Subject: [aprsisce] D74 with APRSIS32 won't transmit

 
Hi folks,

Not sure if this is particular to the D74 or APRSIS32... I have the
Kenwood TH-D74 configured for KISS 12, and the Interface for KISS is
USB. USB is configured for COM use. The whole lot is hooked via USB to
my laptop which is running Linux. 'dmesg' on Linux shows the radio
serial port as /dev/ttyACM0, as expected. The device files under
dosdevices show this as COM33.

APRSIS32 is running under Wine, and it properly displays RF traffic
received by the radio. I can also fire up Putty (instead of APRSIS32,
so no com port fighting), and talk to the radio (send "id" and the radio
responds "TH-D74". So I know that the USB connection is working and
that I can both send and receive. The port type is SimplyKISS, COM port
set to COM33. I've even done the system.reg hack for COM33, just in
case, though all the com ports seem to show up when configuring the
device port. The Transmit Enabled box is checked.

I have turned off Enable / Internet access and APRS-IS, to force using
the radio.

But when I hit the Transmit button on APRSIS32, nothing happens. No
transmit. What am I missing?

Greg KO6TH






Join APRSISCE@groups.io to automatically receive all group messages.