Re: Web Server


Robert Kelley
 

Thanks Lynn.  I enabled DEV mode and set up the IS-Server ports on the host and client.  Looking at the logs now, I have the Host bound to the local IP/Port, which I would think is ok, but when when I set the same up for the client instance, it will not bind to the host's ip/port.  It's almost like something is blocking it.  I have the firewall disabled on both systems and the client can ping the host PC.

The logs from the client are below:

Port(TCP Server):2017-11-05T01:57:09.930 Restarting Reader...
Port(TCP Server):2017-11-05T01:57:09.953 TCPListener Running on @192.168.1.9 or 192.168.1.9:8150 (0 OpenCmds, 0 CloseCmds)
Port(TCP Server):2017-11-05T01:57:09.953 Binding(192.168.1.9) or 192.168.1.9:8150
Port(TCP Server):2017-11-05T01:57:09.953 bind errno 10049
Port(TCP Server):2017-11-05T01:57:09.953 Bind(192.168.1.9) or 192.168.1.9:8150 Failed
Port(TCP Server):2017-11-05T01:57:09.953 bind(@192.168.1.9) Failed
Port(TCP Server):2017-11-05T01:57:09.953 hwnd(000B03E0) msgSubStatus(0) NOT 
Port(TCP Server):2017-11-05T01:57:09.953 Delaying Restart for 59976/60000 msec


Here are is the log from the Host instance:

WinMain:2017-11-05T01:43:31.465 Restore Saved ALWAYS Enable
WinMain:2017-11-05T01:43:31.934 Starting Port(TCP Server)
Port(TCP Server):2017-11-05T01:43:31.934 TCPListener Running on @192.168.1.9 or 192.168.1.9:8150 (0 OpenCmds, 0 CloseCmds)
Port(TCP Server):2017-11-05T01:43:31.934 Binding(192.168.1.9) or 192.168.1.9:8150
Port(TCP Server):2017-11-05T01:43:31.935 Bound(192.168.1.9)=>192.168.1.9:8150


That's going to be enough for me for one night!  Hopefully I will be able to pick this project back up soon!

Thanks,
Bobby

Join APRSISCE@groups.io to automatically receive all group messages.